More Ubuntu? - ATI 9600 and SBLive

Another post about ubuntu? Where will it end?I was fairly excited from thursday evenings antics of getting things working on my machine at home, I thought I’d give it a try with my dev machine at uni. My graphics card, a 9600 (yes ATI, I know!) had been screwed since the day I’d put on Dapper, and to be honest, as I’m not using it that much for GL stuff, I wasn’t really bothered about it. After installing the ATI drivers, them not working and reinstalling the fglrx xorg drivers, I managed to get it working nicely within about 30 mins. This wiki page may help if you’re experiencing similar problems. In my case, my driver was loading, but I was having a problem with libdri.a menaing 3d acceleration got switched off. Anyway, glxgears is now shuvving out a good 3000+ fps so I’m happy enough with that.Aha, I thought, I’ll give the soundcard a bash – a 6 year old SBLive Platinum complete with live drive. Although this (with some tweaking in alsamixer) give outputs on the pci card, the front bay wasn’t getting any output to the headphone socket. I tried to install and compile the latest emu10k drivers from alsa, but then everything got screwed up and no drivers were loading. I removed them and reinstalled what I had before. I carried on with my troubles, inspecting my front bay for any connection problems, notcing one fairly major one…..having the headphones in the mic input – doh! I’d do well to check the obvious things first in the future.

comments powered by Disqus